VisiLogic 9.8.80

**Unitronics’ VFDs: Ladder Functions**
You can now use VisiLogic's convenient Drag & Drop Ladder functions to run Unitronics’ line of VFDs.

**Memory Map**
The appearance of the memory map has been updated, improved, and now enables you to drill down into the memory allocation by clicking Analyze, at the bottom of the window.

**SD Browser**
You can enable your end user to navigate to the user application and to the operand list. Access the:
- user application via User_APP(*V=5)
- operands via User_APP(*D=8)

**New CRC**
FB Protocol now offers a new checksum: CRC_16_L_INIT_ZERO

**Ethernet TX RX**
You can now track the number of bytes sent/received per socket via new system operands. These SIs record the number of packets received or transmitted per socket. They apply to all Ethernet communications.
The number of packets received per socket is stored in these integers as follows:
- Sockets 1 - 4 : SI 301 - SI 304
- In controllers offering more than 4 sockets, such as V700
  Sockets 5 - 8: SI 305 - 308
The number of packets transmitted per socket is stored in these integers as follows:
- Sockets 1 - 4 : SI 311 - SI 344
- In controllers offering more than 4 sockets, such as V700:
  Sockets 5 - 8: SI 315 - 388

**Registration**
Beginning with this version, please note that user registration is required for VisiLogic software.
It is a simple process that takes only a few minutes.

**Discontinued FBs**
Please note that the last version to support FBs Accelerate and Trend (Legacy version only) will be VisiLogic 9.8.80, OS 4.6.19.
These FBs will be discontinued. This means that in later version, they will not appear in the FBs menu or be supported by OS.
As of this version, you can use VisiLogic to configure and run Unitronics’ line of VFDs. Unitronics Motion Inverters (UMIs) are available in Single Phase and Three Phase. The list of drives may be found on the Unitronics website.

Features include:

- EMC Filters, Built-In
- Modbus RTU fieldbus
- Broad range of Operating Temperatures
- Sensorless Vector and Torque control
- Braking units - Built-in
- STO (Safe Torque Off)
- Heavy-Duty overload capacity
- Mounting options: Wall, Flange, Rail

You can now color-code comments by right-clicking the Comment icon.

The String Library for V130 now supports 24 and 32 strings.

An updated USB Driver is now included in the VisiLogic installation updates, CP210x Driver v10.1.1 i

The appearance of the memory map has been updated and improved.

The User_App folder is now accessible via SD Browser.

You can now track the number of bytes sent/received per socket via new system operands:

- SI 301 - 308 Number of EtherNet RX bytes
- SI 311 - 318 Number of EtherNet TX bytes
### VisiLogic 9.8.64

<table>
<thead>
<tr>
<th><strong>Remote Operator for Mobile</strong></th>
<th>The Help menu now offers a link that will access the App store. In addition, the Help topic Remote Operator via Mobile App now contains QR codes that you can scan with your mobile to get the app.</th>
</tr>
</thead>
</table>
| **Ladder: 2X the Space**    | VisiLogic Ladder nets are now wide, and reach completely across your PC screen - no empty areas.  
This gives you twice the editing space.                                                                                                     |
| **Switching I/O Configurations** | Once you have added I/O Expansion Modules to your project, you can create variations called 'I/O Module Configurations'.  
Configurations are hardware profiles that enable a controller to run the application if it has a physical I/O configuration that is different from the full I/O Configuration in the project. Each profile that you create has an index number.  
You determine which configuration is active by storing a value in SI 205. The application will run according to the selected Config without error.  
To enable your program logic to run correctly when switching configurations, you must map the digital inputs and outputs to MBs, and use these MBs as program conditions instead of Input and Output operands. Since analog I/Os are linked to operands, they do not require any special handling. |
<p>| <strong>Run As Admin</strong>            | VisiLogic and other software utilities are now set to &quot;Run as Admin&quot;.                                                                                                                         |
| <strong>Project Navigation Tree</strong> | Simple, static HMI elements such as lines and circles now appear on the Project Navigation Tree under Static.                                                                                     |
| <strong>Remote Access: Alarms</strong>   | You can now Jump to Display in Alarms when running Remote Access.                                                                                                                           |
| <strong>V700, SI 184: Port</strong>      | SI 184 Indicates which port is installed: 0-none, 1-serial, 2-ethernet, 4-Profibus                                                                                                          |
| <strong>PID Server</strong>              | You can now export using different pictures and data formats. Note that the Excel file is saved as .xls file that cannot be opened in office 2013 but can be                                                                                           |</p>
<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>HMI Zoom</strong></td>
<td>You can now zoom HMI displays to twice their size, when editing displays for V700 and V1040, V1210.</td>
</tr>
</tbody>
</table>
| **Operand Export/import**   | • Separators are now supported when importing/exporting.  
• The CSV of operand descriptions now includes a row of operands types.  
• While importing, VisiLogic now displays a progress bar. |
| **Bin File, Import Export** | • You can also select whether to import Fast operands, preset/current of timers and counters.                                                |
| **Data Table Import**       | When importing a .UPD file, you now have options to Select all and Clear all                                                            |
| **Project Memory Map**      | Project memory map now displays topic sizes.                                                                                               |
| **SMS Configuration**       | SMS configuration now supports Eastern Europe language set.                                                                               |
| (V2xx only)                 |                                                                                                                                              |
| **VisiLogic GUI:**          | The VisiLogic interface in Russian has some additions and correction..                                                                       |
| **Russian**                 |                                                                                                                                              |
| **Printing**                | Comments are fully printed when printing Ladder.                                                                                           |
| **Data Table export**       | Each Data table column can be assigned a special caption and format for export to Excel.                                                    |
| **FB Protocol, CRC**        | A new type, CRC-16/BYPASS is now supported.                                                                                               |
| **Keyboard symbols**        | Virtual keyboards now have the underscore symbol where the copyright symbol was held.                                                      |

**VisiLogic 9.8.30**

- Minor fixes in VisiLogic
VisiLogic 9.8.22

In this version:

- Hardware Configuration now supports four new Samba models.

A new I/O configuration, TA22, is now available in 3.5", 4.3", and 7" screen sizes. Models SM35-J-TA22, SM43-J-TA22, and SM70-J-TA22 comprise:
  - 12 Digital Inputs, in total. These may function as npn/pnp inputs, or be configured to include:
    - 1 HSC/Shaft-encoder
    - 2 Analog/Digital Inputs
    - 2 Thermocouple / PT100 inputs
  - 8 Transistor pnp Outputs (source)
  - 2 Analog Outputs, 12-bit

- The I/O RA22 configuration has now been released in the 7" screen size. the SM70-J-RA22, offering:
  - 12 Digital Inputs, in total. These may function as npn/pnp inputs, or be configured to include:
    - 1 HSC/Shaft-encoder
    - 2 Analog/Digital Inputs
    - 2 Thermocouple / PT100 inputs
  - 4 Relay Outputs
  - 4 npn Outputs (sink)
    2 Analog Outputs, 12-bit

- Vision 700: Profibus The V700 can now act as a Profibus slave, joining the V430, V350, and V130.

- New HMI Element: List of Meters
  List of Meters enables you to display completely different versions of the same meter by changing an index number.

VisiLogic 9.8.18
In this version:

- Hardware Configuration supports two new Samba models. The SM35-J-RA22, with a 3.5” color touchscreen, and the SM43-J-RA22 with 4.3” both provide the same I/O configuration:
  - 12 digital inputs. 2 may be configured as analog, 2 as PT100/TC, and 1 as HSC/shaft-encoder inputs
  - 2 analog inputs
  - 8 relay outputs
  - 2 analog outputs

- Color Ladder Regions
  You can now visually mark Ladder nets by right-clicking the left-hand strip next to the left Ladder rail and selecting Background Color. You can select multiple nets, and color different nets different colors. This colors only the side strip; in order to color the entire net, Project>Properties>Colors tab, and check Select entire net. You can select a color and save it by clicking Add to Custom Colors.

**VisiLogic 9.8.2**

Minor version changes.

**VisiLogic 9.8.0**

This version supports the following features:

- **The new Vision700 controller**
  V700-T20BJ is a powerful PLC + HMI that comprises a beautiful 7" built-in color touchscreen.
  The V700 belongs to the same Vision division as the V1210, V1040, and V570, and supports the same Snap-in I/O and I/O Expansion modules, as well as all of the same high-level functionality.
  In addition, this controller comprises a built-in Ethernet port that supports 8 sockets, a USB programming port and a RS232/485 port. You can also order and install two additional COM ports, both a CANbus port and an additional serial port which may be RS232/485 or a Profibus port.
  Note that your V700 Ethernet applications will not use the standard Ethernet
system operands. Check the Help topic Vision700 - Using Ethernet to learn more.

- **Samba43 & Samba7: Expanded Memory**
  VisiLogic version 9.7.74 and up includes firmware, OS 4.1.15 and Boot 2.2.41 and later. This firmware nearly doubles the memory capacity of Samba models SM43 and SM70.

  Note that:
  
  - Beginning from VisiLogic version 9.7.74, when you download an application to a SM43 or SM707 that is running firmware previous to OS 4.1.15 and Boot 2.2.41, VisiLogic will request that you update the firmware. This will delete the application in the controller.
  
  - This firmware upgrade includes both Boot and OS. Boot files can only be downloaded via a serial connection.
  
  - If you use UniDownload Designer, make sure that you include OS 4.1.15 and Boot 2.2.41 or later along with the project files. In addition, note that any Downloader files that contain a Boot file can only be downloaded via serial connection.

- **Samba43 & Vision430: New Virtual Keypads**
  Improved, elegant alpha-numeric and numeric virtual keyboards are supported by the OS released with this version of VisiLogic. Beginning from VisiLogic version 9.7.74, when you download an application to a SM43 or V430 that is running an OS previous to OS 4.1.15, VisiLogic will request that you update the firmware.
  After the OS is updated, and you download an application from VisiLogic 9.974 and up, the controllers will display the new keyboards.

- **3G Modem Support**
  Vision and Samba controllers now support the Cinterion EHS6T 3G modem. Note that the modem must be running firmware version 03.001.

  Note that as of this version, the function block PLC DataCom is no longer supported.

**VisiLogic 9.7.44**

This version supports:

An addition to the Vision line, the Vision430™, 10 models with a 4.3" graphic touch-screen and onboard I/Os.

- **V430-J-RH2**
  - 12 digital inputs. 2 may be configured as analog, and 3 as HSC/shaft-encoder
inputs
- 6 relay outputs

- **V430-J-R34**
  - 22 digital inputs. 2 may be configured as analog, and 3 as HSC/shaft-encoder inputs
  - 12 relay outputs

- **V430-J-TR34**
  - 22 digital inputs. 2 may be configured as analog, and 3 as HSC/shaft-encoder inputs
  - 8 relay outputs
  - 4 high-speed npn transistor outputs

- **V430-J-RH6**
  - 8 digital inputs. 2 may be configured as analog, and 1 as a high-speed input
  - 4 analog inputs
  - 6 relay outputs

- **V430-J-RA22**
  - 12 digital inputs. 2 may be configured as analog, 2 as PT100/TC, and 1 as HSC/shaft-encoder inputs
  - 2 analog inputs
  - 8 relay outputs
  - 2 analog outputs

- **V430-J-TRA22**
  - 12 digital inputs. 2 may be configured as analog, 2 as PT100/TC, and 1 as HSC/shaft-encoder inputs
  - 2 analog inputs
  - 4 relay outputs
  - 2 analog outputs
  - 4 high-speed npn transistor outputs

- **V430-J-T2**
  - 12 digital inputs. 2 may be configured as analog, and 3 as HSC/shaft-encoder inputs
  - 12 transistor outputs. 7 may be configured as high-speed outputs

- **V430-J-T38**
  - 22 digital inputs, 2 may be configured as analog, and 2 as HSC/shaft-encoder inputs
  - 16 transistor outputs. 7 may be configured as high-speed outputs

- **V430-J-TA24**
  - 12 digital inputs. 2 may be configured as analog, 2 as PT100/TC, and 1 as HSC/shaft-encoder input
- 2 analog outputs
- 10 transistor outputs. 5 may be configured as high-speed outputs

- **V430-J-B1**
  - This model does not comprise an I/O configuration

## VisiLogic 9.7.24

This version supports:

Two new Samba models with a 4.3” graphic touch-screen and onboard I/Os.

- **SM43-J-R20**
  - 12 Digital Inputs, may be wired to include 1 HSC/Shaft-encoder input
  - 2 analog inputs (when digital inputs are set to pnp)
  - 8 Relay Output

- **SM43-J-T20**
  - 12 Digital Inputs, may be wired to include 3 HSC/Shaft-encoder input
  - 2 analog inputs
  - 8 Transistor Outputs

- **BACnet Configurator**
  - Vision controllers now support a BACnet to MODBUS Gateway device, available as GW-BAC1.
  - Use the UniBACnet Configurator, located under the Tools tab on the toolbar, to create a configuration file for the BACnet to MODBUS Gateway.
  - Download this file to the GW-BAC1 in order to set up communications between a Vision controller and BACnet slave devices.

- **V130 SNMP Trap**—now supports SNMP V2C Extended trap message.

- **VisiLogic GUI Language**—additional text translation for VisiLogic GUI.
  - (Languages – French, Russian, Turkish, Polish, Chinese)

## VisiLogic 9.7.7

This version:

- Supports a new modem, the Cinterion BGS2T. This modem will replace the Cinterion MC55i, which has been classified as end-of-life by its manufacturer.

- Fixes a few minor issues that were reported in the previous version, as detailed in the VisiLogic bug report.
**VisiLogic 9.7.0**

This version supports Samba, a new highly compact controller with a 3.5" graphic touch-screen and onboard I/Os.

Samba is especially suited for small machine applications.

Two models are available:

**SM35-J-R20**

- 12 Digital Inputs
  - May be wired to include 1 HSC/Shaft-encoder input,
  - 2 analog inputs (when digital inputs are set to pnp)

- 8 Relay Outputs

**SM35-J-T20**

- 12 Digital Inputs
  - May be wired to include 3 HSC/Shaft-encoder input,
  - 2 analog inputs

- 8 Transistor Outputs

---

**VisiLogic 9.6.0**

- **New Remote I/O Module: EXF-RC15**
  The EXF-RC15 is a stand-alone high-speed Remote I/O Module. It offers 9 digital inputs, 4 digital transistor outputs, and 2 relay outputs. Three inputs can be set via wiring and software to function as high-speed counters/Shaft-encoders. The four transistor outputs may function as high-speed PWM/PTO outputs.
  The EXF-RC15 functions as a node in a Vision UniCAN network. Note that the module is programmed in VisiLogic, download is via USB port.
• **SMS**
  SMS messages now support different languages. Note that the default language, English, supports most European languages.

• **HMI Element: SD Browser**
  - A Send File button, that writes the name of a selected file to write a file name to a vector of MIs
  - An MB to change the sort order of the files from new to old and back
  - The ability to display either .csv or .txt files

• **FB Protocol: new CRC options**
  Includes CRC-16_B (big endian), and 2 additional CRC-IBM suited to MODBUS: CRC-16_ANSI_L (little endian) and CRC-16_ANSI_B (big endian)

• **CANLayer2**
  2 new utilities: Send RTR and Send RTR Ex.

• **Download options via Project Properties**
  Choose to filter the display of Download messages via Project> Properties> Download Messages.

• **New utility: 'Read 1.25 mS Counter'**
  Increments a counter every 1.25 mSec.

• **UTC**
  UTC now supports operand types XI and XDW.

• **USB driver**
  Now supports Windows 64-bit.

• **Interrupt**
  Utilis> Debug> Interval Start and End functions are now supported in Interrupt subroutines.

• Remote Access now supports the following:
  - Alarm screens for V1040
  - DW operand values in Hex format
  - Custom keyboards
• **HMI Elements, Text Images**
  Particularly suited for displaying Chinese/Japanese/Korean HMI support (Enhanced Vision only)
  
  o "Fit to Size" is according to the biggest/longest text
  
  o Binary and List text image – supporting one font size in all elements
  
  o Using standard HMI palette for back and fore colors
  
  o Optimize size function for text images variables: binary text image, list text image+ gradients
  
  o Select background colors for text of image button from palette of buttons colors – gradient and flat

• **HMI Elements, Numeric**
  Choose to display asterisks (*) to mask password entry.

This release also includes:

• **OS, Profibus and Ethernet**
  Profibus and Ethernet cannot co-exist in the same application. The factory-installed OS supports Ethernet. The release comprises a separate OS for applications comprising Profibus.
  If your application uses Profibus, install the appropriate OS from Connection > Communication & OS, and select the OS tab.
  Click Check, and follow the on-screen instructions.

• Help file fixes

• Updated System Operands descriptions

**VisiLogic 9.5.0**

☐ Chinese/Japanese/Korean HMI support (Enhanced Vision only)
  These double-byte languages are supported by a new fixed text element: Text Image.
- New Alarm Screens for V1040/V1210 (Enhanced Vision)
  These are attractively designed and make good use of the Big Vision screens.

- New Alarm option: List Alarm Configuration (Enhanced Vision only)
  Previous to the version, Alarms were always displayed according to their ID numbers. You can now choose to display Alarms in the order in which they activate.

- Import/Export HMI Displays--now with Jump Conditions
  A .vld file now includes Jump conditions.

- Graphic Images
  PNG and CMYK format are now supported.

- String Library
  A new Get Next button on the library toolbar enables you to jump to the next unoccupied line.

- Trend HMI Element: Curve Name (V1040/V1210)
  This now supports up to 22 characters for display on the HMI screen.

- HMI Properties Window
  Use the Tab to move between properties.

- Download Modes Warning (Enhanced Vision only)
  Users are now warned that the PLC battery must be in place and functional in order to carry out Download.

- Signature Log
  Now contains a new column: Download Type.

- Operand Values: Connection> Import/Export Operand Values to File
  Enables you to take a 'snapshot' of operand values.

- Ladder Function: Utils> Immediate> Frequency Measurement based on HSC
  You can now configure the Permissible Deviation parameter to receive raw values at a resolution of 16 µsec (micro-seconds).

- Ladder Function: Fill Vector
  Now supports all bit operand types.
MODBUS IP: Slave Address via Operand
To indirectly provide a Slave ID number, click the Slave ID cell and link an operand.

CANopen: Change COB ID
You can now indirectly provide the ID via operand.

New CRC type
Fletcher has been added to the algorithm list.

New System Operands
These include:
- SB 112: On-Board USB port detected
- SB 111: (V560 only) Disable Virtual Keypad
- SB 178: (V130/V350 only) Profibus Card Detected
- SI 246: (V1210/V1040 only) Improve Display of Complex HMI elements. 1- 30
- SDW 49 Signature Log Checksum

VisiLogic 9.4.0

- Faster Image Download
  Only new images are downloaded with an application.

- New, glossy Virtual Keyboards for V1040/V1210
  Compatibility Issue: OS version 3.6.0 and higher, are not compatible with applications written in VisiLogic versions previous to 9.4.0 that comprise keypad entry variables.

- Information Mode, Enhanced Vision only
  - The Software section now includes the VisiLogic application name, and the PC User Name of the computer on which the application was written.
  - You can view now up to 64 files from SD card (was up to 8)

- String Libraries
  These now offer the following enhancements:
  - If strings that are exported to Excel are defined to certain fonts,
those fonts are retained at export, and if the Excel file is imported to a different library, the font definitions are maintained.
- You can now select which String Library to display within the HMI editor in VisiLogic, including an option to display the longest text.

- **Edit multiple HMI static elements**
  If you select, for example, two rectangles, and right-click them, common editable properties such as foreground may be edited for both rectangles.

- **Export Display to .bmp**
  A new toolbar button in the HMI editor enables you to capture the current display.

- **Project Memory Map**
  Now also shows DLUs.

---

**VisiLogic 9.3.1**

- **RTC to ASCII Ladder function**
  Additional date formats are now available within the function

  - **HMI Time Functions Language support**
  Day of the Week/ Month, now offer a drop-down box that enable you to select the display language

  - **Function Data Table Clear Row**
  The Clear Row parameter now supports all operand types

- **Download via Ethernet**
  Ethernet download is now supported by Wizard.

- **OS, Boot and Factory Boot**
  Use the new tab in the "Communication and OS" to switch to different modes: OS, Boot and Factory Boot.
**VisiLogic 9.3.0**

- **New Enhanced Vision Series Models**
  V1210
  The newest Big Vision with a 12.1" screen is now supported in Hardware Configuration.
  V350-35-TR6 and V130-33-TR6
  8 digital and 8 analog inputs, 6 relay outputs
  V350-35-TR20 and V130-33-TR20
  12 digital and 2 analog inputs, 6 relay outputs
- **PROFIBus Slave** – Enhanced Vision only
  Vision controllers can now function as slaves within the Profibus Network.
- **Immediate Read HSO** – Enhanced Vision only
  In an application based on a controller with high-speed outputs (HSO) supporting Step Control, Immediate Read HSO Position can be used to immediately record the current value of the Current Position parameter--without regard to the program scan. Note that Immediate Read CANNOT be used in an 2.5 mS or 1.25 mS Interrupt Routine.
- **PTO Functions**
  These functions are now also supported by Enhanced Vision models V350/V130-TR6 and V350/V130-TR20.
- **CANbus Messages to Data Table** - Enhanced Vision only
  You can automatically record CANbus messages to a Data Table. This is applicable to all of the different types of CANbus supported by Vision controllers.
- **New Download Project default mode**
  As of this version, the default Download Project mode for both Standard and Advanced Vision controllers is: "All & Burn". "All and
Burn" enables the PLC to recover its application in the event of total power loss—including battery failure. In addition, if you select a different Download Project mode, VisiLogic asks if you wish to set your selection as the new default.

- DNS Resolver
  Now supports up to 80 characters.
- VisiLogic Graphics Navigation panel
  When you insert images into your HMI application, VisiLogic now offers a user-friendly proprietary navigator. You can revert to the default Windows method via Project>Properties General tab, and deselecting the option: Selecting Images: use the VisiLogic Navigation Panel

**VisiLogic 9.2.0**

- V1040
  - The Alpha-Numeric keyboard has been attractively redesigned, and now occupies the entire display.
  - Trends can now be shown across the entire screen
  - The Numeric keyboard and Alarm displays no longer appear on a black background; they now appear over the current display.
  - You can control the coordinates, and therefore the position of the Numeric keypad and Alarm screen.
  This is done via new SIs: **SI244 X Coordinates, Num Keypad/Alarm screen** and **SI445 Y coordinates** Edit these values to move these elements to the desired location.

- Enhanced Models Download
  The list of Download types is now located under the Download button, in addition to the Download menu option.

- New modems
  Sierra Wireless GL6100 and Cinterion MC55iT are now in SMS and GPRS Modem Services
• V1040; V560 and V350 – ESC button is now supported on Alarms, keyboards and Info menus
• TCP/IP Socket Init: HTTP port was formerly set to Port 80; it can now be set by the user via MI

VisiLogic 9.0.1

• V1040 support
  The new Big Vision with a 10.4" screen is now supported in Hardware Configuration.
  This is also the first Vision to offer a USB programming port.
• 65536 colors (16-bit)
  From VisiLogic 9 on, all images will be 64K colors (16-bit). However, images in older projects that are opened with this version will remain 8-bit (256 colors).
  Note: older projects including many images, especially where image are switched rapidly to provide animation, may run at reduced speeds, and in certain cases may not function properly.
• UniVision Licensing
  This new utility helps you to protect your intellectual property. Use it in conjunction with the UniVision Licensing stand-alone utility, which may be freely downloaded from http://unitronics.com/Content.aspx?page=Downloads.
• New GSM/GPRS Modems
  Cinterion MC55 and Sierra Wireless GL61000.
• PTO Functions
  These enable Simple Motion Control via software; they are based on the high-speed outputs in certain Vision 130/350 models.
• HMI Editor:
  New view shows the Display screen and Jumps in separate tabs at the top of the editing window.
Compatibility Issues

• Version Incompatibility
Do not download a project built with versions lower than VisiLogic 9.xx, to a controller installed with the system files released with VisiLogic 9.xx (Boot V2.002 (xx), BinLib V1.010 (xx) and OS V3.003 (xx)) and up. This will result in version mismatch.
VisiLogic V9.xx is compatible with Boot V2.002 (xx), BinLib V1.010 (xx) and OS V3.003 (xx) and up.

• Modems
Certain older modems are not supported in VisiLogic 9. If you wish to update a project containing modems to VisiLogic 9, check the COM Init function to see if your modem is supported. It is highly recommended to delete and redefine the COM Init function.

VisiLogic 8.6.3

This version included Bug Fixes, but no added features.

VisiLogic 8.6.2

The VisiLogic Help Menu now contains a link to the new Unitronics support forum, at http://forum.unitronics.com/

The Optimizer tool now locates duplicate instances of coils.

You can now select different keyboard types for keypad-entry variables: numeric range; RTC; time functions; UTC; Counter; Timer.

VisiLogic 8.6.1
New Hardware Support

New Vision controllers
V350-33-TR6 and V130-33-TR6  8 Digital (configurable via wiring to include 2 Analog (current/voltage) and 1 HSC/Shaft-encoder), 4 Analog Inputs (current), 6 Relay Outputs, 2 high-speed npn Transistor Outputs

New Snap-in Modules
- V200-18-E46B  18 Digital (including 2 shaft encoders), 9 Analog Inputs •15 Relay 2 pnp/npn HSO, 2 Analog Outputs
- V200-18-E62B  30 Digital (including 2 shaft encoders), 2 Analog Inputs •15 Relay 28 pnp, 2 pnp/npn HSO, 2 Analog Outputs

VisiLogic Menu Changes
As a result of screen size and resolution, some users have been unable to view the entire VisiLogic menu. This release includes a new menu 'Utils'.
Utils comprises the following menus: HMI, Alarms, Clock, Immediate, Debug, Idle, and Backup Security.

New HMI Feature: HMI Element Default Setting
You can now set default settings for attributes such as Foreground and Background.
This can be applied from project properties→ colors tab or from the HMI element itself.

New Save Trends to SD feature (enhanced only)
Using the Start and Stop Saving Trend to SD now appends data to a single .utr file. In addition, new SBs 117-118 enable you to display .utr segments on the HMI Display.
Note that previous to this version, using the Start and Stop Saving Trend to SD functions recorded a single, unsegmented .utr file. If the function Stop Recording Trend was used to pause the recording, when Start Saving was again activated, the function automatically overwrote the .utr file of the same name.
To revert to the previous functionality, and overwrite the .utr file, set SB 116, SD Trends to SD: Set to Overwrite .utr.

**Built-in Web Server:** there have been a number of improvements, including a new Memory Allocation Compile button built into the Web Server Configurator.

**OS Download:** this can now be performed via RS485.

**String Library, .csv import:** is no longer dependant on Microsoft Office being installed on the PC.

**CANbus baudrate:** now supports 10kbps.

**Improved Email** function GUI.

**Improved PID** captions & description in PID Ladder menus.

**Updated message** – When trying to open Visilologic version which has not been registered – Detailed message will appear.

**Compilation Errors:**

Ø “Compiled STL code reached the maximum size” changed to “subroutine ladder code size exceeds limit – Split subroutine to solve problem”.

Ø “Buffer full” messages changed to more detailed messages in order to guide the user how to solve the error.

Ø SMS Send - Compile error when there is no phone number and last received number.

Ø If HMI element exceeds size limit – “The HMI Element variable XXX exceeds the size limit”

Ø Loadcell – if hardware status messages and FB loadcell config status messages are linked to the same operand – compilation error.

**Delete phone numbers** from SMS phone book.

**Examples:** New examples available
VisiLogic 8.6.0

This is a partial list of features in this version

New Hardware Support

New Vision models: V130-33-TA24, V35033-TA24
12 Digital Inputs, configurable via wiring to include 2 Analog, 2
PT100/TC, and 1 HSC/Shaft-encoder Input
10 Transistor Outputs, 2 Analog Outputs

New Snap-in Module: V200-18-E46B
18 Digital, 9 Analog Inputs, 15 Relay, 2 pnp/npn, 2 Analog
Outputs

Modem:
Wavecom FASTRACK SUPREME

Hardware Documentation
In versions previous to 8.6.0, installing VisiLogic also installed a
Hardware Documentation library. This library is now available as a
separate download from

New methods for creating compressed data files
These include PLC Clone files *.cxx, *.vxx), files for
UniDownloade(*.dvi, *.vdf), and HMI cache files (*.urc, *.ura).

New Ladder functions

SD
Cloning
Use Ladder functions, Information mode, or VisiLogic Project files
to clone a complete PLC and application, Data Tables, or operand
values from a PLC or install such clone files to a PLC of the same
model.
Via SD Card Explorer, you can also remotely transfer these files from a PLC's SD card to PC, and from PC to PLC--Remote 'no-hands' PLC cloning.

**Safely Remove SD Card**
Use this to check when the card may be safely removed.

**email attachments**
Enhanced Vision controllers with SD cards enable you to email an attached file located on the SD card.

**COM**
- SNMP Trap
- SNMP Community Name
- DNS Resolver
- Telegram Parser

**Data Tables**
- Delete Rows

**Utilities**

**String Library**
- Import/Export .csv

**Data Tables**
- Import/Export .csv

**Information Mode**
Now offers a built-in CANbus 'sniffer' in addition to the existing ones for Ethernet and serial communications.

**Project Optimizer**
Run the Optimizer to view a list possible improvements that you can make in your project. In the results window, double click a line to jump to the appropriate location in the project.
Built-in Web Server
A number of improvements make the Web Server easy to use.

Enhanced Digital Signatures (now supported by Enhanced models)
A number of additions enable Vision PLCs to meet standards in niche industries such as pharmaceuticals.

International Keypads (Enhanced Touch-screen only)
You can select a keyboard in a different language for Keypad Entry Variables in the Font Handler.

HMI Tweaks: Improving the user experience
Netbook support
Scroll bars now enable the user to view the HMI Editor when working on small-screen netbooks.

Project Navigator
Access Hardware Configuration, String Library, and WebServer from the navigation tree.

Password Variable
Now supports Display text from String Library (Enhanced Vision only)

HMI Display Bit
Turns ON when a Display is on-screen. The selected bit is now shown in View> HMI Information

CANbus SAE J1939
Officially released from Beta. J1939 is currently running in installations across the globe.

Previous Versions
VisiLogic 8.02: What's New?

CanLayer2 ScanEX, new function
Scan_Ex enables you to receive all CANbus messages from devices via CAN Layer 2.

SB 108 Press "Enter" 1x (V130)
Normally, when a user enters a Keypad Entry value on a V130 HMI, the user must press the Enter button twice:
Once to 'approve' the value
Once to jump to and activate the next variable.
You can control this by turning both SB 76 and SB 108 ON in your application. Note that the user can press ESC to exit keypad entry mode.

VisiLogic 8.01: SD Suite Software
SD Cards: New Ladder Functions (Enhanced only)

**SD Password**
Guards SD data.

**Folder Report**
Reports the number of files currently in an SD folder, and the number of files can still be created in that folder.

**SD to/from Data Table**
Use these to read and write data between Data Tables and SD card.

**SD Trend**
Record an entire or partial trend to a .utr file in the SD card Trends folder.

**Display Trend**
Display Trend directly from a .utr file via HMI element Trend from SD.

**SD Excel**
Pull numeric data or text strings from the PLC.
and use delimiters to structure a line; then create an Excel file on an SD Card. Supports .csv & .txt lines

**Data Blocks**

Create, and then read/write PLC data to storage areas in the SdBBlocks folder on a SD card.

SD Data Blocks may reach a total of 4G.

Use Windows Explorer to store any type of file onto an SD card, such as .html or .jpg. Via Ladder, read and write these files in 'chunks' of 512 bytes.

**Data Files**

You can also use these functions to pull data from the PLC and create files on the SD card.

**SD Cards: New HMI Features (Enhanced only)**

**SD Card Browser**

Via an HMI button, display the contents of an SD folder, enable users to delete and execute files.

**Trend from SD**

This is a new HMI variable in the Graphs menu.

**String Library: Store Strings in 16 libraries**

**String Libraries** have been increased to 16, making it easy to create a single application that can serve end-users in 16 languages.

Strings can be imported/exported from/to Excel.

Both of the above features are in String Library> File

Find Unreferenced Strings is a new tool on the String Library toolbar.

**Complex Web Server (Enhanced, TCP/IP)**

The Vision can host pages with a variety of colors, fonts, links to other sites, and scripts. The controller must comprise a TCP/IP port, and must be connected to an Ethernet network.

**New Hardware Support**

**Vision570 + onboard I/Os**
Vision V570-57-T34 OPLCs belong to the Color Vision Series, comprising a 5.7” touchscreen (this model will be released to market shortly)

**XL I/O Expansion Modules**
XL I/O modules comprise enhanced I/O configurations and detachable I/O connectors. In addition, some modules comprise a built-in adapter for communicating with the PLC and providing power to the other expansion modules in the system.

**Ladder Function: Frequency Measurement**
New Ladder function on the Immediate menu enables you measure High-speed Input frequency with resolution and accuracy of 0.01 Hz.

**SAE J1939 CANbus Protocol, CANbus modes**
If your Vision comprises a CANbus port, you can use:
SAE J1939: Configure, then Send/Receive PGNs. Located on COM> J1939.
CANopen + CANLayer2: now available as simultaneous modes as option in COM Init.
New Ladder Element: Map Register bytes can aid in managing CANOpen messages, reordering, expanding, and distributing.
**New Ethernet features**

New functions available on the COM TCP/IP menu are:

- **Ping**
- Email>SMTP Mail Authentication
- SNMP(slave)

**Built-in Web Server (Enhanced,TCP/IP)**

Advanced Options enable user logo, and logo via external link.
New option ‘Editable’ enable user to send value to PLC via web interface

**DF1 Slave**

Enables Vision to be slave to the DF1 AB protocol, COM >DF1

**Data Tables**

New Ladder functions on the Data Tables menu:
Copy a Data Table Row to Operand Vector.
Copy a Vector of Operands to a Data Table Row.

**Alarms**

Up to 16 Alarms are now supported by V130, and 14 are supported in History.

**OEM: Image Customization**

You can replace Unitronics proprietary system images in your application, by using the utility Project> System Images. Among the images you can replace are:

- Information Mode: replace the Unitronics logo
- System Busy: replace the VisiLogic image
- Start-up Splash screen: replace the DOS-style screen

**New Ladder Tools**
Advanced Find and Replace: Edit> Replace Operand now supports Replace in HMI Displays.

Address Vector: when addressing an Operand, you can assign a vector of operands a name, and automatically assign consecutive numbers.

Vector: Shift Left now supports MB, XB, and additional register types.

**On-line Test Mode**
Go to HMI Screen: when you are in Test mode, you can jump the VisiLogic application to the display that you see on the controller’s HMI screen by clicking the HMI icon on the Test toolbar

**HMI Variable Features (Color Division)**

Select Touch keyboard type: Select this when creating a Keypad Entry Variable.

Numeric Variable-Range: You can now change colors according to range of values.

Display Background –Image: Right-click a display, and select a background image.

Graphical button: You can now select an image when creating a button.

**HMI Improvements**

Text: when you create/edit a text box, there are new Alignment options; in addition, older options work in accordance with expected standards.

**Fixed Issue: Vista .emf**
This format can now be viewed when running Vista

**What's New?**

**SD Cards : a new approach**
VisiLogic 7.01: What's New?

Note that in order to use new version features you must download the latest OS, via the menu Connection> Communication & OS> Operating System tab.

Some of the information below refers to Vision Divisions. These are:

Standard Vision: V120, V230, V260, V280, V290-BW, and V530
Enhanced Vision: V570, V350, and V130

New SD functions enable you to save Trends

Remote Access Zoom

You can now view an HMI screen at 1,2,3,4 times its size, or zoom it to fill your PC display.

Web Server (Enhanced only, supporting TCP/IP)

Enriched web interface, now supports logos.

CANbus: Run Simultaneous modes

In addition to CANopen + UniCAN, you can now run CANopen + CANbus, Layer 2 by selecting the relevant CANbus option in the COM Init function (Enhanced Vision only).

New Ladder Functions

Immediate: HSC Frequency Measurement Utilities

Version 7.00: What's New?

VisiLogic 7.0.0

Note that in order to use new version features you must download the latest OS, via the menu Connection> Communication & OS> Operating System tab.

Please note that not all features are documented.
Note that some of the information below refers to Vision Divisions. These are:

**Standard Vision:** V120, V230, V260, V280, V290-BW, and V530

**Enhanced Vision:** V570, V350, and V130

**Vision350--Palm-size PLC with COLOR**

Vision350 OPLCs belong to the Color Vision Series, comprising a 3.5” TFT touchscreen that can show over 1000 displays; with a 3.5MB capacity for images & fonts.

7 models are currently available, each with a different on-board I/O configuration which may include PT100/TC and analog outputs. Via local and remote I/O Expansion Modules, V350 can support up to 512 I/Os. Additional features include:

- Built-in operating panel containing an LCD and a keypad
- 1 built-in serial port: RS232/RS485
- Optional: the user may order and install additional ports: RS232/RS485/Ethernet and CANbus
- SD card support

**Remote I/O (all models supporting CANbus)**

The EX-RC1 remote I/O module adapter enables you to distribute I/O Expansion Modules throughout your system. The adapter is connected to a master PLC by UniCAN, Unitronics’ proprietary CANbus protocol, and functions as a slave device within that network. Each adapter may be connected to up to 8 I/O expansion modules. Up to 512 I/Os may be connected to a single controller, depending on the models you select.

Additional details regarding this new feature will soon be available.

**SD Cards: Removable Memory Storage (Enhanced only)**
Enhanced Vision controllers now support SD cards. The V570 supports standard SD cards; V130 and V350 support micro SD cards. You can:

- Enable a VisiLogic application to store complete Data Tables, and to log Data Table rows to an SD card
- Import data on a SD card into Data Tables via VisiLogic
- Apply a password to prevent programs being uploaded from the controller to an SD card
- Store Alarms History on SD

Use Information Mode to:
- Upload a VisiLogic application and OS firmware onto an SD card, and then copy them into other controllers
- Upload the entire Data Table structure of a controller

Use Unitronics SD Tools utility, located on the VisiLogic Tools menu, to:
- Convert and view the data on the SD card via PC
- Export that data to Excel or as an .csv file

'Clone' a PLC application.

**Send e-mail (all models supporting TCP/IP)**

This function enables a controller to send an email in response to Ladder conditions. In order to send email, the controller must comprise a TCP/IP port, and must be connected to an Ethernet network with access to an SMTP or ESMTP server.

**Web Server (Enhanced only, supporting TCP/IP)**

Enhanced Vision controllers can act as servers and host web pages that can display operand values including timers and counters, and Alarm warnings. The controller must comprise a TCP/IP port, and must be connected to an Ethernet network.

**Trends HMI Variable: New Feature (Enhanced only)**

**V130 support**

Up to 4 Trends, each holding 2 Curves
**Y-axis value**
The minimum and maximum value can now be linked to MI, enabling the value to be entered via keypad

**Remote Access**
You can now view Trends in Remote Access

**Information Mode: Additions for V130**
View CANbus settings
See connected I/O Expansion Modules
View the PLC Name
Monitor Ethernet communications as they flow through the port

**1.25 mS Interrupt Routine (Enhanced only)**
This function is supported by Enhanced Vision models only. The 1.25 mS is called by naming a subroutine _Interrupt 1.25 mS_. It functions exactly like the 2.5mS Interrupt routine.

**New Stop Mode Subroutine (All models)**
If you include a subroutine named:
_RUN_TO_STOP_
this subroutine will run a single time when the PLC enters Stop mode. Note the addition of a new related system operand SB 301, which turns on for a single cycle when the PLC goes into stop mode

**New Boot Mode Features (Enhanced only)**
The OS version released with VisiLogic 7.00 also adds new Boot Mode features

OS Download
an OS via COM2, Ethernet, or CANbus.

Boot Info Mode: This gives you the ability to check software and certain hardware versions, view and edit Unit ID as well as certain CANbus, serial, and Ethernet settings. You enter this mode just like standard Information mode: when you are in Boot mode,
touch (or in the case of the V130 hold down the <I> key) for 7 seconds.

**Stepper via High-speed Output (V570 only)**
Snap-in I/O modules offer high-speed outputs. If you are using a V570 with any model Snap-in I/O module, VisiLogic 7.00 or higher and the relevant OS, you can use these outputs to control stepper motors.

Note that any acceleration and deceleration that is needed to arrive at Target safely and accurately must be implemented via Ladder.

**Import/Export Displays**
You can export displays and save them as .vld files, then import them into other projects.

**HMI Variable Features (Enhanced/Color Division)**
Password: you can now display text in the password variable
Numeric Variables: can now display MF values
Binary Text, List of Texts: supports background color, text from String Library
List of Texts, Range of Texts: you can now determine background and foreground colors, and apply them to all rows
List of Images: Select groups of images; when in the Select Image box, by holding down the Ctrl button and clicking images
Project>Properties>Colors: you can select default colors for:
-Buttons: Pressed/Unpressed states
-Focus and Focus Text
-Default Line color

**UniDownloader**
The UniDownloader package enables you to build a complete, compressed project and send it anywhere to be installed in a PLC using a standalone downloader. Your end user will be able to
download the application, but will not be able to view or modify it. The tool can download applications and OS.


**UniEDS**

Use the UniEDS to open CANopen EDS files. The utility is located on the Tools menu.

**A additional Features (All models)**

*Struct: supports MI to Inputs*

- **UDP** and **TCP** RAW functions are located on the **COM>TCP/IP>UDP** menu. Use them to send a vector of raw data to a remote Vision, broadcast the data to the entire network, or receive a stream of data and write it to a vector of registers.

- **FB Protocol**: now supports STX in checksum calculations

- **New Function**: Replace String

- Keystroke Ctrl + Z now undoes the last action

**Additional Features (Enhanced only)**

- **OS download via Ethernet**

- **Alarms**: Supported in Remote Access

- **Virtual Keypads**: Enhanced Touchscreen Models
  - You can use SI 49 to change between three keypad types

- **Relevant X Operand types are now supported in NUM to ASCII functions, and in the Events FB**

- **Color models only**: Trend (Legacy) FB- you can write a value into SI 48 to change the color of the Trend as it is being drawn

**Issue: CANopen compatibility break**

- The CANopen System Operand addressing scheme
changed as of **VisiLogic version 7.00, OS 2.00 (Standard Division) OS 5.02 (Enhanced Division)**.

You can choose to continue editing older applications using previous VisiLogic versions contained in the VisiLogic Version Swapper. Note that in this case the controller **must** use an older OS.

However, if you choose to update the application and OS, note that you must change the system operands according to the following table.

<table>
<thead>
<tr>
<th>System Integers</th>
<th>System Double Words</th>
</tr>
</thead>
<tbody>
<tr>
<td>Old</td>
<td>New</td>
</tr>
<tr>
<td>200</td>
<td>211</td>
</tr>
<tr>
<td>201</td>
<td>212</td>
</tr>
<tr>
<td>202</td>
<td>213</td>
</tr>
<tr>
<td>203</td>
<td>214</td>
</tr>
<tr>
<td>204</td>
<td>215</td>
</tr>
<tr>
<td>205</td>
<td>216</td>
</tr>
<tr>
<td>206</td>
<td>217</td>
</tr>
<tr>
<td>207</td>
<td>218</td>
</tr>
<tr>
<td>208</td>
<td>219</td>
</tr>
<tr>
<td>240</td>
<td>220</td>
</tr>
<tr>
<td>241</td>
<td>221</td>
</tr>
<tr>
<td>242</td>
<td>222</td>
</tr>
<tr>
<td>243</td>
<td>223</td>
</tr>
<tr>
<td>244</td>
<td>224</td>
</tr>
</tbody>
</table>
Utilities
To see what updates have been released for Unitronics software utilities, such as DataXport, Remote Access and UniOPC Server, check http://www.unitronics.com/Content.aspx?page=Downloads.

VisiLogic Application Examples

When you install VisiLogic, an Examples folder is created on your hard disk, containing field-tested VisiLogic (.vlp) sample applications. You can copy these sample applications and adapt them for your own use—if, for example, an application is written for the V120, you can select the V230 via Hardware Configuration.